Fri, 19 Apr 2024 16:23:45 UTC | login

Information for RPM perl-encoding-4:2.22-439.module_el8.4.0+646+45e06e4a.x86_64.rpm

ID577321
Buildperl-Encode-3.01-439.module_el8.4.0+646+45e06e4a
Nameperl-encoding
Version2.22
Release439.module_el8.4.0+646+45e06e4a
Epoch4
Archx86_64
DraftFalse
SummaryWrite your Perl script in non-ASCII or non-UTF-8
DescriptionWith the encoding pragma, you can write your Perl script in any encoding you like (so long as the Encode module supports it) and still enjoy Unicode support. However, this encoding module is deprecated under perl 5.18. It uses a mechanism provided by perl that is deprecated under 5.18 and higher, and may be removed in a future version. The easiest and the best alternative is to write your script in UTF-8.
Build Time2021-01-20 19:09:14 GMT
Size68.42 KB
8835af1dd14347e513010fd030a9997b
LicenseGPL+ or Artistic
Provides
perl(encoding) = 2.22
perl-encoding = 4:2.22-439.module_el8.4.0+646+45e06e4a
perl-encoding(x86-64) = 4:2.22-439.module_el8.4.0+646+45e06e4a
Obsoletes No Obsoletes
Conflicts
perl-Encode < 2:2.64-2
Requires
perl(:MODULE_COMPAT_5.30.1)
perl(Carp)
perl(Config)
perl(Encode)
perl(Filter::Util::Call)
perl(constant)
perl(strict)
perl(utf8)
perl(warnings)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
Recommends No Recommends
Suggests
perl(PerlIO::encoding)
Supplements No Supplements
Enhances No Enhances
Files
1 through 6 of 6
Name descending sort Size
/usr/share/man/man3/encoding.3pm.gz7.91 KB
/usr/share/doc/perl-encoding/README1.06 KB
/usr/share/doc/perl-encoding/Changes109.27 KB
/usr/share/doc/perl-encoding/AUTHORS2.52 KB
/usr/share/doc/perl-encoding0.00 B
/usr/lib64/perl5/vendor_perl/encoding.pm22.41 KB
Component of
1 through 3 of 3
Buildroot ascending sort Created State
module-perl-IO-Socket-SSL-2.066-820230223114759-0ccef39c-build-324066-252391 2023-05-01 18:09:00 expired
scrmod-perl-DBD-Pg-3.7-820230223114759-d2fc5d76_1+357-build-324361-252877 2023-05-02 15:44:50 expired
module-perl-DBD-Pg-3.7-820230223114759-d2fc5d76-build-355572-297176 2023-07-13 13:57:29 expired