Fri, 09 Dec 2022 06:13:06 UTC | login

Information for RPM ruby-3.1.2-141.module_el9+156+2e0939d1.src.rpm

ID590377
Nameruby
Version3.1.2
Release141.module_el9+156+2e0939d1
Epoch
Archsrc
SummaryAn interpreter of object-oriented scripting language
DescriptionRuby is the interpreted scripting language for quick and easy object-oriented programming. It has many features to process text files and to do system management tasks (as in Perl). It is simple, straight-forward, and extensible.
Build Time2022-06-23 08:41:10 GMT
Size14.48 MB
ced10c406a1f4534dfcb5a0e67863084
License(Ruby or BSD) and Public Domain and MIT and CC0 and zlib and UCD
Buildrootmodule-ruby-3.1-920220606174420-9-build-284793-107958
Provides
ruby = 3.1.2-141.module_el9+156+2e0939d1
ruby-bundled-gems = 3.1.2-141.module_el9+156+2e0939d1
ruby-debuginfo = 3.1.2-141.module_el9+156+2e0939d1
ruby-debugsource = 3.1.2-141.module_el9+156+2e0939d1
ruby-default-gems = 3.1.2-141.module_el9+156+2e0939d1
ruby-devel = 3.1.2-141.module_el9+156+2e0939d1
ruby-doc = 3.1.2-141.module_el9+156+2e0939d1
ruby-libs = 3.1.2-141.module_el9+156+2e0939d1
rubygem-bigdecimal = 3.1.1-141.module_el9+156+2e0939d1
rubygem-bundler = 2.3.7-141.module_el9+156+2e0939d1
rubygem-io-console = 0.5.11-141.module_el9+156+2e0939d1
rubygem-irb = 1.4.1-141.module_el9+156+2e0939d1
rubygem-json = 2.6.1-141.module_el9+156+2e0939d1
rubygem-minitest = 5.15.0-141.module_el9+156+2e0939d1
rubygem-power_assert = 2.0.1-141.module_el9+156+2e0939d1
rubygem-psych = 4.0.3-141.module_el9+156+2e0939d1
rubygem-rake = 13.0.6-141.module_el9+156+2e0939d1
rubygem-rbs = 2.1.0-141.module_el9+156+2e0939d1
rubygem-rdoc = 6.4.0-141.module_el9+156+2e0939d1
rubygem-rexml = 3.2.5-141.module_el9+156+2e0939d1
rubygem-rss = 0.2.9-141.module_el9+156+2e0939d1
rubygem-test-unit = 3.5.3-141.module_el9+156+2e0939d1
rubygem-typeprof = 0.21.2-141.module_el9+156+2e0939d1
rubygems = 3.3.7-141.module_el9+156+2e0939d1
rubygems-devel = 3.3.7-141.module_el9+156+2e0939d1
Obsoletes No Obsoletes
Conflicts No Conflicts
Requires
/usr/bin/cmake
/usr/bin/dtrace
/usr/bin/hostname
autoconf
gcc
git
gmp-devel
libffi-devel
libyaml-devel
make
multilib-rpm-config
openssl-devel
procps
readline-devel
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
zlib-devel
Recommends No Recommends
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
1 through 29 of 29
Name ascending sort Size
libruby.stp8.01 KB
macros.ruby1001.00 B
macros.rubygems6.41 KB
operating_system.rb4.33 KB
ruby-1.9.3-mkmf-verbose.patch567.00 B
ruby-2.1.0-Enable-configuration-of-archlibdir.patch787.00 B
ruby-2.1.0-Prevent-duplicated-paths-when-empty-version-string-i.patch2.17 KB
ruby-2.1.0-always-use-i386.patch772.00 B
ruby-2.1.0-custom-rubygems-location.patch3.40 KB
ruby-2.3.0-ruby_version.patch10.68 KB
ruby-2.7.0-Initialize-ABRT-hook.patch2.03 KB
ruby-2.7.1-Timeout-the-test_bug_reporter_add-witout-raising-err.patch1.45 KB
ruby-3.1.0-Don-t-query-RubyVM-FrozenCore-for-class-path.patch1.47 KB
ruby-3.1.1-ossl_ocsp-use-null.patch1.38 KB
ruby-3.1.2-ossl-tests-replace-sha1.patch23.54 KB
ruby-3.1.2.tar.xz14.40 MB
ruby-3.2.0-Build-extension-libraries-in-bundled-gems.patch12.04 KB
ruby-3.2.0-Detect-compaction-support-during-runtime.patch8.39 KB
ruby-3.2.0-define-unsupported-gc-compaction-methods-as-rb_f_notimplement.patch12.88 KB
ruby-3.2.0-define-unsupported-gc-compaction-methods_generated-files.patch19.10 KB
ruby-bundler-2.4.0-bundle-update-bundler-test-in-ruby.patch1.33 KB
ruby-exercise.stp1.08 KB
ruby.spec115.08 KB
rubygems.attr394.00 B
rubygems.con1.46 KB
rubygems.prov870.00 B
rubygems.req2.73 KB
test_abrt.rb130.00 B
test_systemtap.rb1.76 KB
Component of No Buildroots