Tue, 27 Sep 2022 11:34:28 UTC | login

Information for RPM nodejs-1:18.2.0-1.module_el8.7.0+1175+23de1610.i686.rpm

ID593654
Namenodejs
Version18.2.0
Release1.module_el8.7.0+1175+23de1610
Epoch1
Archi686
SummaryJavaScript runtime
DescriptionNode.js is a platform built on Chrome's JavaScript runtime for easily building fast, scalable network applications. Node.js uses an event-driven, non-blocking I/O model that makes it lightweight and efficient, perfect for data-intensive real-time applications that run across distributed devices.
Build Time2022-06-24 15:46:59 GMT
Size13,847,823
c3788b2006c579dca208ecad988c99eb
LicenseMIT and ASL 2.0 and ISC and BSD
Provides
bundled(c-ares) = 1.18.1
bundled(corepack) = 0.10.0
bundled(histogram) = 0.9.7
bundled(icu) = 71.1
bundled(libuv) = 1.43.0
bundled(llhttp) = 6.0.6
bundled(nghttp2) = 1.47.0
bundled(nghttp3) = 0.1.0-DEV
bundled(ngtcp2) = 0.1.0-DEV
bundled(uvwasi) = 0.0.12
bundled(v8) = 10.1.124.8
nodejs = 1:18.2.0-1.module_el8.7.0+1175+23de1610
nodejs(abi) = 18.2
nodejs(abi18) = 18.2
nodejs(engine) = 18.2.0
nodejs(v8-abi) = 10.1
nodejs(v8-abi10) = 10.1
nodejs(x86-32) = 1:18.2.0-1.module_el8.7.0+1175+23de1610
nodejs-punycode = 2.1.0
npm(corepack) = 0.10.0
npm(punycode) = 2.1.0
Obsoletes No Obsoletes
Conflicts
node <= 0.3.2-12
Requires
/bin/sh
/usr/bin/node
ca-certificates
ld-linux.so.2
ld-linux.so.2(GLIBC_2.1)
libbrotlidec.so.1
libbrotlienc.so.1
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.2)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.10)
libc.so.6(GLIBC_2.15)
libc.so.6(GLIBC_2.16)
libc.so.6(GLIBC_2.17)
libc.so.6(GLIBC_2.2)
libc.so.6(GLIBC_2.2.4)
libc.so.6(GLIBC_2.28)
libc.so.6(GLIBC_2.3)
libc.so.6(GLIBC_2.3.2)
libc.so.6(GLIBC_2.3.3)
libc.so.6(GLIBC_2.3.4)
libc.so.6(GLIBC_2.4)
libc.so.6(GLIBC_2.6)
libc.so.6(GLIBC_2.7)
libc.so.6(GLIBC_2.9)
libcrypto.so.1.1
libcrypto.so.1.1(OPENSSL_1_1_0)
libcrypto.so.1.1(OPENSSL_1_1_0g)
libcrypto.so.1.1(OPENSSL_1_1_1)
libcrypto.so.1.1(OPENSSL_1_1_1b)
libcrypto.so.1.1(OPENSSL_1_1_1e)
libdl.so.2
libdl.so.2(GLIBC_2.0)
libdl.so.2(GLIBC_2.1)
libgcc_s.so.1
libgcc_s.so.1(GCC_3.0)
libgcc_s.so.1(GCC_3.4)
libgcc_s.so.1(GCC_7.0.0)
libgcc_s.so.1(GLIBC_2.0)
libm.so.6
libm.so.6(GLIBC_2.0)
libm.so.6(GLIBC_2.1)
libm.so.6(GLIBC_2.27)
libpthread.so.0
libpthread.so.0(GLIBC_2.0)
libpthread.so.0(GLIBC_2.1)
libpthread.so.0(GLIBC_2.2)
libpthread.so.0(GLIBC_2.2.3)
libpthread.so.0(GLIBC_2.3.2)
libpthread.so.0(GLIBC_2.3.3)
libssl.so.1.1
libssl.so.1.1(OPENSSL_1_1_0)
libssl.so.1.1(OPENSSL_1_1_1)
libstdc++.so.6
libstdc++.so.6(CXXABI_1.3)
libstdc++.so.6(CXXABI_1.3.5)
libstdc++.so.6(CXXABI_1.3.8)
libstdc++.so.6(CXXABI_1.3.9)
libstdc++.so.6(GLIBCXX_3.4)
libstdc++.so.6(GLIBCXX_3.4.11)
libstdc++.so.6(GLIBCXX_3.4.14)
libstdc++.so.6(GLIBCXX_3.4.15)
libstdc++.so.6(GLIBCXX_3.4.18)
libstdc++.so.6(GLIBCXX_3.4.20)
libstdc++.so.6(GLIBCXX_3.4.21)
libstdc++.so.6(GLIBCXX_3.4.9)
libz.so.1
nodejs(engine)
openssl >= 1:1.1.1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rtld(GNU_HASH)
Recommends
nodejs-full-i18n(x86-32) = 1:18.2.0-1.module_el8.7.0+1175+23de1610
npm >= 1:8.9.0-1.18.2.0.1.module_el8.7.0+1175+23de1610
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
Page:
1 through 50 of 83 >>>
Name ascending sort Size
/usr/bin/corepack45
/usr/bin/node43,604,408
/usr/lib/.build-id0
/usr/lib/.build-id/c10
/usr/lib/.build-id/c1/1e19b3eebe9f5047865dcacfb27d07edc56e8d24
/usr/lib/dtrace0
/usr/lib/dtrace/node.d12,324
/usr/lib/node_modules0
/usr/lib/node_modules/corepack0
/usr/lib/node_modules/corepack/LICENSE.md1,063
/usr/lib/node_modules/corepack/README.md7,700
/usr/lib/node_modules/corepack/dist0
/usr/lib/node_modules/corepack/dist/corepack.js524,857
/usr/lib/node_modules/corepack/dist/npm.js82
/usr/lib/node_modules/corepack/dist/npx.js82
/usr/lib/node_modules/corepack/dist/pnpm.js83
/usr/lib/node_modules/corepack/dist/pnpx.js83
/usr/lib/node_modules/corepack/dist/vcc.js13,130
/usr/lib/node_modules/corepack/dist/yarn.js83
/usr/lib/node_modules/corepack/dist/yarnpkg.js86
/usr/lib/node_modules/corepack/package.json2,560
/usr/lib/node_modules/corepack/shims0
/usr/lib/node_modules/corepack/shims/corepack285
/usr/lib/node_modules/corepack/shims/corepack.cmd180
/usr/lib/node_modules/corepack/shims/corepack.ps1789
/usr/lib/node_modules/corepack/shims/nodewin0
/usr/lib/node_modules/corepack/shims/nodewin/corepack323
/usr/lib/node_modules/corepack/shims/nodewin/corepack.cmd218
/usr/lib/node_modules/corepack/shims/nodewin/corepack.ps1865
/usr/lib/node_modules/corepack/shims/nodewin/npm313
/usr/lib/node_modules/corepack/shims/nodewin/npm.cmd208
/usr/lib/node_modules/corepack/shims/nodewin/npm.ps1845
/usr/lib/node_modules/corepack/shims/nodewin/npx313
/usr/lib/node_modules/corepack/shims/nodewin/npx.cmd208
/usr/lib/node_modules/corepack/shims/nodewin/npx.ps1845
/usr/lib/node_modules/corepack/shims/nodewin/pnpm315
/usr/lib/node_modules/corepack/shims/nodewin/pnpm.cmd210
/usr/lib/node_modules/corepack/shims/nodewin/pnpm.ps1849
/usr/lib/node_modules/corepack/shims/nodewin/pnpx315
/usr/lib/node_modules/corepack/shims/nodewin/pnpx.cmd210
/usr/lib/node_modules/corepack/shims/nodewin/pnpx.ps1849
/usr/lib/node_modules/corepack/shims/nodewin/vcc313
/usr/lib/node_modules/corepack/shims/nodewin/vcc.cmd208
/usr/lib/node_modules/corepack/shims/nodewin/vcc.ps1845
/usr/lib/node_modules/corepack/shims/nodewin/yarn315
/usr/lib/node_modules/corepack/shims/nodewin/yarn.cmd210
/usr/lib/node_modules/corepack/shims/nodewin/yarn.ps1849
/usr/lib/node_modules/corepack/shims/nodewin/yarnpkg321
/usr/lib/node_modules/corepack/shims/nodewin/yarnpkg.cmd216
/usr/lib/node_modules/corepack/shims/nodewin/yarnpkg.ps1861
Component of No Buildroots